Technomorous

Něco ke čtení

Sdílet: Twitter | Facebook | Google+

Tak dokonale se poslední dny bavím čtením různých historických informačně a komunikačně technických dokumentů, že mám skoro chuť odložit Dell U2412M, na jeho místo dát sériový terminál a ve studiu pokračovat na něm.

Dokonce jsem si opět přečetl svoji oblíbenou trojici, kterou bych chtěl nabídnout:

Tyhle tři dokumenty jsou psané v rozmezí dvou dekád. První na počátku osmdesátých let, třetí na konci devadesátých a ten prostřední zhruba uprostřed. I když se všechny do jisté míry zabývají historií a ne realitou své tehdejší doby, právě jejich způsob pohledu na historii říká víc, než ta historie samotná.

A jako bonus tu mám odkaz na jeden web, který si archivuju na lokální disk: historie CB opakovače Faltus. Stejně jako si lidé od počítačů dřív doma bastlili periferie ke svým osmibitovým miláčkům, v devadesátých letech se stejným úsilím jiná skupina lidí budovala komunikaci pro všechny. CB pásmo u nás (s dvacetiletým zpožděním proti U.S.A.) zažívalo ohromný boom, kanály praskaly ve švech a pokud chtěl někdo v Praze něco říct, musel si "vystát frontu" - tedy několik desítek minut či dokonce hodin trpělivě čekat, než bude chvilka ticha. Stejně, jako si dneska už kromě nadšenců nikdo normální periferie pro běžné použití nebastlí, tak i dálková komunikace běžných lidí probíhá úplně jinak - standardizovaně, komerčně, nudně. Zůstala jen historie k přečtení.

Tak čtěte!

(PS: Pokud používáte Firefox 57, tak vám asi nefungují odkazy na Gopher. Opravdu. Vás. Upřímně. Lituju.)


Jméno
Web
E-Mail
Nejsem člověk
Text komentáře

1. Peter Kotrčka (30. listopadu 2017, 9:17)
Pre FF57 existuje overbite plugin ktorý správí to, že to otvorí v tej gopher bráne na sdf.org

2. Logout (30. listopadu 2017, 9:40)
[1] Já vím, psal o tom jak Cameron, tak Jirka. Takže se nakonec stejně neotevírají ve Firefoxu, ten už dostává čisté HTML. I proto je mi uživatelů FF57 líto :)

3. Jinej Honza (30. listopadu 2017, 13:44)
Litovat není třeba, Firefox je IMHO víc než v pohodě.

Já si to (druhý) přečetl v tomhle:
http://gopher.floodgap.com/gopher/
http://gopher.floodgap.com/gopher/gw

Myslím že zrovna kvůli gopheru browser fakt měnit nebudu :)

4. Logout (30. listopadu 2017, 14:09)
[3] Ty možná ne, u mě už se stalo. Nejde jen o gopher, ale prostě o to že XUL/XPCOM je dobrá technologie a jen proto, že nemají dost kvalitní programátory pro její rozvoj, není třeba ji opouštět ve prospěch úplně hloupých WebExtensions. Ostatně u FF jsem vydržel tak dlouho právě kvůli XUL/XPCOM doplňkům, bez nich je to prostě jen další browser v řadě. Ale to by byly debaty zcela mimo mísu tohohle blogu...

5. faraon (30. listopadu 2017, 21:09)
Mě ty odkazy hodí chybu i ve FF18, takže tu 57 bych zase tak rychle nezatracoval ;-)
A Chromajzl se to rovnou pokusí vygooglit, ten vůbec ani netuší co to gopher je.

6. Peter Kotrčka (30. listopadu 2017, 23:32)
5: potrebujes plugin, ale ten chce firefox 38 - 56: http://gopher.floodgap.com/overbite/

7. Logout (1. prosince 2017, 9:57)
Zde kancelář pro uvádění diskusí na vlastním blogu na pravou míru.

Schopnost pracovat s Gopherem ztratil Firefox ve verzi 4, nicméně díky XUL/XPCOM ji mohl až do verze 56 (včetně) získat zpět pomocí pluginu OverbiteFF. Ten přidává podporu protokolu na síťové úrovni, takže je to funkčně i uživatelsky stejné, jako na FF 1-3. Přímo na odkazu uvedeném o jeden komentář výše lze stáhnout několik historických verzí pluginu, které fungují i ve FF starším než je 38. Jsou ke stažení pouze pomocí Gopheru (už jsem se Camerona ptal, je to záměr, jen nevím jaký) - takže napoprvé je nutno použít Gopher/Web gateway z komentáře číslo 3.

Děkuji za pozornost :-)

8. nula (2. prosince 2017, 10:05)
[3] Já jsem taky asi v pohodě, i když o FF 57 bych to určitě netvrdil. Aktuální řešení přístupu na Gopher mě moc nenadchlo, byŤ OverbiteWX mám pro jistotu už všude nainstalovaný.

Ale v práci vlastně přístup na Gopher nepotřebuji (jedině, že líp se mi hledá na Gopherphedii než na oficilním rozhraní Wikipedie) a doma mám všude Lynx a/nebo Netscape


TOPlist